Page 1 of 1

Weak Drag on OG Zillion

Posted: Tue Jul 17, 2018 8:22 am
by Tony9
I bought a used OG Zillion awhile back from Japan for a pretty good price. Everything seems pretty good with it internally and it feels smooth but the drag seem especially weak. I literally have to lock down the drag star as tight as I could for it to be usable, I would estimate about 3lbs of drag or so when locked down.

I've replaced the stock drags with Carbontex. I've very lightly greased the washers but still the same result. Thinking I've over greased it, I took it back apart and wiped down the drag washers but it still didn't make much of a difference.

I've also tried changing out the belleville washer from a Tatula CT (same part numbers IIRC). I noticed a slight improvement but nothing significant.

Just wondering what else could be wrong. I appreciate any input. Thanks!

Re: Weak Drag on OG Zillion

Posted: Tue Jul 17, 2018 8:25 am
by Cal
what type of line are you using?

I would try again with new washers and no grease to see if that helps. Drag should have been restored with new washers.

Re: Weak Drag on OG Zillion

Posted: Tue Jul 17, 2018 8:42 am
by Tony9
Cal wrote:what type of line are you using?

I would try again with new washers and no grease to see if that helps. Drag should have been restored with new washers.


I am using braid on that reel. I've put some electrical tape around the spool before putting the braid on. I forgot to mention but I've also tried mono backing and then braid and it's still the same. Yea I really thought it was just the washers. I will probably have to take it apart again when I get the chance and flush out the washers and discs and try it completely dry of grease to see if it helps.

Thanks!

Re: Weak Drag on OG Zillion

Posted: Sat Jul 21, 2018 2:04 am
by IlliniDawg01
Is it possible you are missing a spring washer (or they are flattened) between the drag star and the roller bearing collar?

DaveJ

Re: Weak Drag on OG Zillion

Posted: Tue Jul 24, 2018 8:08 pm
by PikeRoadBassn
Sounds like 2 spacers are missing. 1 sits on top of the roller clutch inner tube, one sits on top of the handle support bearing.

Re: Weak Drag on OG Zillion

Posted: Thu Aug 02, 2018 7:47 pm
by 78Staff
spacers missing or flattened is what I was thinking as well. you can always tell if you put one back together and don't get them right as you will have basically no drag through the range and then all the drag will kick in the last half- turn or so.

Re: Weak Drag on OG Zillion

Posted: Sun Aug 26, 2018 10:59 am
by Tony9
Thanks for the responses everyone. I finally got around to working on the Zillion. Since I have a few SV103s I swapped out the some of the parts and it made a significant difference. The washer that sits on top of the drag clicker and belleville washers is noticeably thicker than the stock one. A quick email to TTT and I have all the parts I needed. I ended up running the stock SV103 washer with the stock washer and new belleville washers. Tightened down, the drag is a lot stronger now. I measured about 6.5-7lbs with a full spool with my fish scale (max drag should increase as more line is out but I didn't measure). Not bad at all. It should be more than enough for my intended use.