Weak Drag on OG Zillion

Here's your chance to speak directly with the TT Gear Crew. Post your questions, comments, experiences regarding tackle maintenance and super tuning
User avatar
Tony9
Elite Angler
Elite Angler
Posts: 289
Joined: Fri Feb 26, 2016 6:38 am
Location: CA Delta

Weak Drag on OG Zillion

Postby Tony9 » Tue Jul 17, 2018 8:22 am

I bought a used OG Zillion awhile back from Japan for a pretty good price. Everything seems pretty good with it internally and it feels smooth but the drag seem especially weak. I literally have to lock down the drag star as tight as I could for it to be usable, I would estimate about 3lbs of drag or so when locked down.

I've replaced the stock drags with Carbontex. I've very lightly greased the washers but still the same result. Thinking I've over greased it, I took it back apart and wiped down the drag washers but it still didn't make much of a difference.

I've also tried changing out the belleville washer from a Tatula CT (same part numbers IIRC). I noticed a slight improvement but nothing significant.

Just wondering what else could be wrong. I appreciate any input. Thanks!

User avatar
Cal
Site Admin
Site Admin
Posts: 10783
Joined: Tue Oct 05, 2004 5:31 pm
Location: TT Headquarters
Contact:

Re: Weak Drag on OG Zillion

Postby Cal » Tue Jul 17, 2018 8:25 am

what type of line are you using?

I would try again with new washers and no grease to see if that helps. Drag should have been restored with new washers.
Cal, Managing Editor
"fish with mindfulness : beware the darkside"

User avatar
Tony9
Elite Angler
Elite Angler
Posts: 289
Joined: Fri Feb 26, 2016 6:38 am
Location: CA Delta

Re: Weak Drag on OG Zillion

Postby Tony9 » Tue Jul 17, 2018 8:42 am

Cal wrote:what type of line are you using?

I would try again with new washers and no grease to see if that helps. Drag should have been restored with new washers.


I am using braid on that reel. I've put some electrical tape around the spool before putting the braid on. I forgot to mention but I've also tried mono backing and then braid and it's still the same. Yea I really thought it was just the washers. I will probably have to take it apart again when I get the chance and flush out the washers and discs and try it completely dry of grease to see if it helps.

Thanks!

User avatar
IlliniDawg01
Pro Angler
Pro Angler
Posts: 2141
Joined: Sun Mar 17, 2013 8:20 am
Location: Glen Carbon, Illinois

Re: Weak Drag on OG Zillion

Postby IlliniDawg01 » Sat Jul 21, 2018 2:04 am

Is it possible you are missing a spring washer (or they are flattened) between the drag star and the roller bearing collar?

DaveJ

PikeRoadBassn
Elite Angler
Elite Angler
Posts: 393
Joined: Sun Sep 16, 2012 11:05 am

Re: Weak Drag on OG Zillion

Postby PikeRoadBassn » Tue Jul 24, 2018 8:08 pm

Sounds like 2 spacers are missing. 1 sits on top of the roller clutch inner tube, one sits on top of the handle support bearing.

User avatar
78Staff
Elite Angler
Elite Angler
Posts: 504
Joined: Wed Apr 12, 2006 9:56 am
Location: Florida

Re: Weak Drag on OG Zillion

Postby 78Staff » Thu Aug 02, 2018 7:47 pm

spacers missing or flattened is what I was thinking as well. you can always tell if you put one back together and don't get them right as you will have basically no drag through the range and then all the drag will kick in the last half- turn or so.


Return to “Maintenance & SuperTuning Q&A”

Who is online

Users browsing this forum: No registered users and 4 guests